Back to overview
Downtime

Dashboard is unavailable

Feb 07 at 12:21pm UTC
Affected services
Better Stack

Resolved
Feb 07 at 12:28pm UTC

Our dashboard is available again, the faulty switch has been replaced.

Created
Feb 07 at 12:21pm UTC

Better Uptime dashboard is currently unavailable due to a hardware failure of a switch. Our server housing provider is actively resolving the issue. Sincere apologies for the inconvenience.